Напишите программу на паскале) 1.с клавиатуры вводится 3-хзначное число. определить какая из его цифр больше. 2.с клавиатуры вводится 3-хзначное число. определить является ли произведение его цифр 3-хзначным числом. 3.с клавиатуры вводится 4-хзначное число. определить, равна ли сумма первых двух цифр сумме последних двух.

lcjewfyjozo075 lcjewfyjozo075    3   31.05.2019 06:50    0

Ответы
gaynite57 gaynite57  01.07.2020 18:18
program pervoe;
var a,b,c,c1,d,max:integer;
begin
readln(a);
b:=a div 100 ;
c:= a mod 10;
c1:= a mod 100;
d:= c1 div  10;
if(b > c) then max:= b
else max:= c;
if (max < d) then max := d; writeln(max);
readln;
end.
2)program vtoroe;
var a,b,c,c1,d,pro:integer;
begin
readln(a);
b:=a div 100 ;
c:= a mod 10;
c1:= a mod 100;
d:= c1 div  10;
pro:= b * c * d ;
if (pro > 99) and (pro < 1000) then writeln('Yes');
readln;
end.
3)program trete;
var a,b,c,d,e,f,g,j,sum1,sum2:integer;
begin
readln(a);
b:=a div 1000 ;{1}
c:=a mod 10;  {4}
e:=a mod 1000; {234}
f:=e div 100; {2}
g:=e mod 100;{34}
j:=g div 10; {3}
sum1:= b + f ;
sum2:= j + c;
if (sum1 = sum2)  then writeln('Yes')
else writeln('NO');
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика