Напишите программу на Pascal: Напишите среднее значение целых положительных чисел, которые вводятся с клавиатуры (окончание ввода-ввод числа 0)

Anna111864 Anna111864    2   21.05.2020 19:07    1

Ответы
000Данил111111111 000Данил111111111  15.10.2020 05:01

//Pascal

var a,i,s,n:integer;

begin

 s:=0;

 n:=0;

 repeat

    readln(a);

    if a>0 then begin

       n:=n+1;

       s:=s+a;

    end;

 until a = 0;

 writeln('Сумма ',s:5,'  Среднее арифметическое ',s/n);

end.

ТАК) (Я НЕСОВСЕМ УВЕРЕН)

ПОКАЗАТЬ ОТВЕТЫ
новинький2 новинький2  15.10.2020 05:01

--- PascalABC.NET 3.6.2 ---

begin

 ReadSeqIntegerWhile(p -> p <> 0).Where(p -> p > 0).Average.Println;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика