Напишите программу [на pascal], которая вычисляет минимальное из трёх введённых чисел. используйте функцию.

dia651 dia651    2   15.09.2019 07:30    0

Ответы
пороло1 пороло1  16.08.2020 16:18
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!

function Min3(a,b,c:real):=Min(a,Min(b,c));

begin
  var (x,y,z):=ReadReal3('Введите три числа:');
  Writeln('Минимальное: ',Min3(x,y,z))
end.

Пример
Введите три числа: 3.18 -2 5.7
Минимальное: -2
ПОКАЗАТЬ ОТВЕТЫ
Kerisha4 Kerisha4  16.08.2020 16:18
function min(x,y:integer):integer;
begin
if x<y then min:=x else min:=y;
end;
var a,b,c:integer;
begin
readln(a,b,c);
writeln('min = ',min(min(a,b),c));
end.

Пример:
8 2 5
min = 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика