Напишите программу, которая выводит символы с от n до м (в три столбца) напишите фрагмент , в котором будет определяться символ по своему коду напишите фрагмент , в которой будет определяться код символа

AlyaMrr AlyaMrr    2   30.09.2019 09:50    0

Ответы
лолкек67 лолкек67  09.10.2020 05:30

var n,m,i,k:integer; c:char;

begin

// 1

write('n, m: ');

readln(n,m);

k:=0;

for i:=n to m do

begin

write(i,' - ',chr(i),'   ');

k:=k+1;

if k mod 3=0 then writeln;

end;

// 2

write('n: ');

readln(n);

writeln(n,' ',chr(n));

// 3

write('c: ');

readln(c);

writeln(c,' ',ord(c));

end.

Пример:

n, m: 40 60

40 - (   41 - )   42 - *    

43 - +   44 - ,   45 - -    

46 - .   47 - /   48 - 0    

49 - 1   50 - 2   51 - 3    

52 - 4   53 - 5   54 - 6    

55 - 7   56 - 8   57 - 9    

58 - :   59 - ;   60 - <    

n: 100

100 d

c: {

{ 123

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика