Напишите программу, которая выводит полученную последовательность чисел в обратном порядке. Использовать массив для хранения последовательности не разрешается. ---Входные данные---
Во входных строках записаны целые числа, по одному в каждой строке. В последней строке записано число 0.

---Выходные данные---
Программа должна вывести элементы полученной последовательности в обратном порядке в одну строчку, разделив их пробелами.
ПРИМЕР
Ввод
1
2
3
0
Вывод
3 2 1
Ввод
245
-7197
0
Вывод
-7197 245
Желательно на Питоне или Паскале с использованием РЕКУРСИИ(процедуры или функции)!

lear8765 lear8765    1   08.12.2020 03:36    41

Ответы
Aydan204 Aydan204  07.01.2021 03:38

Мне становится страшно за твой уровень развития 0_0

#include <iostream>

using namespace std;

long long b[100000];

int main()

{

   long long a, sum = 0, i = 0;

   while(1)

   {

       cin >> a;

       if(a == 0)

           break;

       b[i] = a;

       i++;

   }

   for(i--; i > -1; i--)

   cout << b[i] << " ";

   return 0;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика