Напишите программу,которая вычисляет сумму: а)первых n натуральных чисел; б)квадратов первых n натуральных чисел

nikitakucherenk nikitakucherenk    1   02.06.2019 15:50    4

Ответы
arturk13 arturk13  03.07.2020 10:55
Решение на паскале:
а)
var sum,i,n: int64;
BEGIN
writeln('Введите N');
readln(n);
for i := 1 to n do
sum := sum + i; // можно написать так inc(sum, i);
writeln('Сумма первых ', n, ' натуральных чисел = ', sum);
END.
б)
var sum,i,n: int64;
BEGIN
writeln('Введите N');
readln(n);
for i := 1 to n do
sum := sum + sqr(i); 
writeln('Сумма квадратов первых ', n, ' натуральных чисел = ', sum);
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика