Напишите программу, которая вычисляет произведение всех чисел, оканчивающихся на 2, из диапазона от 0 до 50.

68Diman 68Diman    2   07.05.2020 08:06    0

Ответы
MAXIM3600 MAXIM3600  14.09.2020 07:23

using namespace

Объяснение:

using namespace std;

int main()

{

 int a,sum=2;

  for (a = 1;a <= 50;a++){

      if(a%10==2){

          sum = sum * a;

      }      

  }

  cout <<sum / 2;

}

ПОКАЗАТЬ ОТВЕТЫ
masha90876 masha90876  14.09.2020 07:23

using System;

using System.Linq;

class NewClass

{

   

   static void Main()

   {

       int[] array = Enumerable.Range(0, 51).ToArray();//диапазон - [0; 50]!

       foreach(var i in array)

           System.Console.Write($"{i} ");

       System.Console.WriteLine();

       System.Console.WriteLine(array.Where(var => var % 10 == 2).Aggregate((var1, var2) => var1 * var2));

   }

}

Объяснение:

Диапазон от 0 до 50 включительно. Если диапазон нужен такой, чтобы 50 не включалось, измените 51 в методе Range() на 50.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика