Напишите программу,которая выбирает максимальное и минимальное из пяти введённых чисел.

Fsyh Fsyh    2   24.06.2019 05:20    6

Ответы
DFV7 DFV7  02.10.2020 10:01
Const
  n = 5;{ это позволяет в одном месте изменить количество чисел }

type
  numeric = real;{ это позволяет в одном месте изменить тип чисел }

var
  max, min: numeric;
  i: integer;
  a: array[1..n] of numeric;

begin
  Writeln('Введите ', n, ' произвольных чисел через пробел');
  Read(a[1]);
  min := a[1]; max := min;
  for i := 2 to n do
  begin
    Read(a[i]);
    if max < a[i] then max := a[i]
    else
    if min > a[i] then min := a[i]
  end;
  Writeln('Минимальное введенное: ', min, ', максимальное: ', max)
end.

Тестовое решение:
Введите 5 произвольных чисел через пробел
34 157 -84.54 14.843 -13.64
Минимальное введенное: -84.54, максимальное: 157
ПОКАЗАТЬ ОТВЕТЫ
volk007volk volk007volk  02.10.2020 10:01
Var mas5: array [1..5] of real;
var a: real;
var i, amax, amin: integer;
begin
amax:=1;
amin:=1;
writeln ('Введите числа: ');
for i:=1 to 5 do  
begin 
read (a);
mas5[i]:=a; 
end;
for i:=1 to 5 do  
begin 
if mas5[i]<mas5[amin] then amin:=i; 
if mas5[i]>mas5[amax] then amax:=i; 
end;
writeln;
writeln (mas5[amin], '  ', mas5[amax]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика