Напишите программу, которая вводит с клавиатуры числа до тех пор, пока не будет введено число 0. в конце работы программы на экран выводится минимальное и максимальное из введенных чисел (не считая 0)

Артём84748 Артём84748    3   27.06.2019 05:20    13

Ответы
mgarkanov mgarkanov  02.10.2020 12:46
{с клавиатуры вводится число a, до тех пор, пока не будет введен 0. Начальное введенное a записывается в min  и max, чтобы потом в цикле было с чем сравнивать}
var
min,max,a:real;
begin
   readln(a);
   min:=a;max:=a;
    while a<>0 do
        begin
             readln(a);
                 if a>max then
                     max:=a;
                 if a<min then
                      min:=a;
         end;
writeln('min: ',min,'  max: ',max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика