Напишите программу, которая в зависимости от введенного возраста добавляет слова «год», «года» или «лет». например, при вводе возраста 1, программа сообщает «1 год», при числе 2 – «2 года», при числе 125 – «125 лет».

av45 av45    1   12.06.2019 22:30    0

Ответы
snysor snysor  10.07.2020 08:56
Var age:integer;
begin
  readln(age);
  if ((age mod 100 >= 10) and (age mod 100 <= 19)) then writeln(age, ' лет')
  else if (age mod 10 = 1) then writeln(age, ' год')
  else if ((age mod 10 >= 2) and (age mod 10 <= 4)) then writeln(age, ' года')
  else writeln(age, ' лет');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика