напишите программу которая в последовательности 20 целых чисел определяет их количество и сумму чётных чисел до первого введеного нуля ПАСКАЛЬ ПРОСТАЯ СХЕМА​

Albina1809 Albina1809    2   15.02.2021 00:20    3

Ответы
mariya1810 mariya1810  17.03.2021 00:27

pascal

Объяснение:

var

 i, kol, summ: integer;

 a: array[1..20] of integer;

begin

 WriteLn('Введите 20 целых чисел: ');

 for i := 1 to 20 do

 begin

   Write('a[', i, '] = ');

   ReadLn(a[i]);

 end;

 for i := 1 to 20 do

   if a[i] <> 0 then

   begin  

      if a[i] mod 2 = 0 then

      begin

       inc(kol);

       summ := summ + a[i];

      end;

   end

   else break;

 WriteLn('Количество четных чисел до первого нуля равно ', kol);

 WriteLn('Их сумма равна ', summ);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика