Напишите программу, которая удаляет из введенной строки любой введенный с клавиатуры символ

vita142 vita142    2   08.05.2020 09:36    0

Ответы
viktoriasvoya viktoriasvoya  14.10.2020 10:46

Тут значительно легче без процедур решить. Вот, получайте!

program prim;

Var

s : string;

t : char;

k: integer;

begin

writeln ('Введите строку');

readln (s);

writeln ('Введите символ, который надо удалить');

readln (t);

while pos(t,s)<>0 do

begin

k:=pos(t,s);

Delete(s, k, 1);

end;

writeln ('Результат после удаления: ');

writeln(s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика