Напишите программу, которая считает знаки пунктуации в символьной строке. к знакам пунктуации относятся символы из набора «.,; : ! ? ». формат входных данных программа получает на вход символьную строку (длина строки не больше 100 символов). формат выходных данных программа должна вывести общее количество знаков пунктуации во входной строке. примеры входные данные выходные данные hi, guys! 2

Y563280 Y563280    2   09.09.2019 07:50    24

Ответы
alinkass alinkass  07.10.2020 02:40
Var s,p:string; k,i:integer;
begin
readln(s);
p:='.,;:!?';
k:=0;
for i:=1 to length(s) do
 if pos(s[i],p)>0 then k:=k+1;
writeln('k = ',k);
end.

Пример:
Hi, guys!
k = 2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика