Напишите программу, которая решает : «дано целое число n. вывести на экран следующее за ним четное число». 12

MrLeysanHD MrLeysanHD    1   03.10.2019 12:20    15

Ответы
Рита496 Рита496  21.08.2020 21:11
#include <iostream>
using namespace std;
int main() {

int n, i;

cin >> n;
i = n + 1;

if ( i % 2 == 0) {
cout << i;
}
else {
cout << n + 2;
}
return 0;
}

не оч красиво, но работает
ПОКАЗАТЬ ОТВЕТЫ
zzizziz zzizziz  21.08.2020 21:11

var n:integer;

begin

readln (n);

if n mod 2 = 0 then write(n+2)

else write(n+1)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика