Напишите программу, которая получает три числа – рост трёх спортсменов, и выводит сообщение "on growth! ", если числа введены по возрастанию, или сообщение 'dont on growth! ', если они введены в другом порядке например: входные данные 165 170 172 выходные данные on growth! например: входные данные 175 170 172 выходные данные dont on growth! с++ только использовать всякие if ,for,while,scanf,printf,#include #include #include ,main,getch, max,min, действия и остаток от деления. если это потребуется.

ffjrppyegxvhd ffjrppyegxvhd    2   03.09.2019 16:30    24

Ответы
xeniapopsoip00ty7 xeniapopsoip00ty7  06.10.2020 15:10
Https://pastebin.com/a1Z4DbQ9

#include "stdafx.h"
#include <iostream>
int main()
{
  int n;
  int save_n=0;
  bool b = true;
  for (int i = 0; i < 3; i++)
  {
    std::cin >> n;
    if (save_n>0&&save_n >= n&&b)
      b = false;
    save_n = n;
  }
  if (b)
   std::cout << "on growth!"<<"\n";
  else
    std::cout << "dont on growth!"<<"\n";
  system("pause");
 return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
апнг1 апнг1  06.10.2020 15:10
#include <stdio.h>
#include <stdlib.h>
#include <locale>

int main()
{
    setlocale(LC_ALL, "RUS");
    int g[3];
    for (int i = 0; i < 3; i++)
    {
        printf("Введите рост %d спортсмена >> ", i+1);
        scanf("%d", &g[i]);
    }
    if (g[0] < g[1] && g[1] < g[2])
        printf("on growth");
    else
        printf("don't on growth");
    system("pause");
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика