Напишите программу,которая получает два целых числа и находит их произведение не используя операцию умножения. учтите, что числа могут быть отрицательными.пример : введите два числа: 10-15,10*(-15)=-150

anechkaaa2 anechkaaa2    1   14.06.2019 20:00    11

Ответы
AKI20 AKI20  12.07.2020 09:13
Var  a, b, prod, i: integer;
begin
  writeln('Введите два числа: ');
  readln(a, b);
  prod := 0;
  if (b < 0) then
    for i := b to -1 do
      dec(prod, a)
  else
    for i := 1 to b do
      inc(prod, a);
  writeln(prod)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика