Напишите программу, которая показывает количество нечетных чисел в числе. ( если можно, то без программы while и не слишком мудро)

ilmir123456789 ilmir123456789    3   29.06.2019 14:20    1

Ответы
Нуртилек2664467 Нуртилек2664467  23.07.2020 14:07
Var
  k:longint;
  d,n:integer;
begin
  Write('Введите натуральное число (1-2147483647): ');
  Read(k);
  n:=0;
  while k>0 do begin
    d:=k mod 10;
    k:=k div 10;
    if (d mod 2)<>0 then Inc(n)
  end;
  Writeln('Количество нечетных цифр в числе равно ',n)
end.

Тестовое решение:
Введите натуральное число (1-2147483647): 35632105
Количество нечетных цифр в числе равно 5
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика