напишите программу которая подсчитывает количество цифр в натуральном числе N введённым с клавиатуры​

Oloii Oloii    2   16.10.2020 10:07    1

Ответы
amaliyaazlzova amaliyaazlzova  15.11.2020 10:09

#include <iostream>

using namespace std;

typedef long long ll;

int main()

{

  ll number, i = 0;

  cin >> number;

  while(number > 0){

      number/=10;

      ++i;

  }

  cout << i;

}

// хитрый вариант с использованием строк на случай если число будет очень большое

#include <iostream>

#include <string>

using namespace std;

int main()

{

  string number;

  cin >> number;

  cout << number.size();

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика