Напишите программу, которая по введенному пользователем натуральному числу n(n < 100) выводит на экран следующую сумму:
1^2+2^2+3^2+⋯+n^2
Для вычисления суммы должен использоваться цикл, нельзя пользоваться готовой формулой.

IlachinaViktori IlachinaViktori    3   08.05.2020 20:23    0

Ответы
tolstuhen tolstuhen  14.10.2020 12:06

python 3:

n = int(input()) # считываем с клавиатуры n

s = 0 # начальное значение суммы

for i in range(1, n + 1): # цикл по i от 1 до n

   s += i * i # увеличиваем s на i * i, то есть i в квадрате

print(s) # выводим s

Можно и короче, например, так:

n = int(input())

s = sum(i * i for i in range(1, n + 1))

print(s)

Или даже в одну строчку:

print(sum(i * i for i in range(1, int(input()) + 1)))

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика