Напишите программу которая отобразит числа в порядке пирамиды паскаля. программа должна вычислить и отобразить 15 этажей пирамиды с++

mintgirl mintgirl    1   01.10.2019 10:01    0

Ответы
Настя61391 Настя61391  09.10.2020 07:33

#include <iostream>

#include <iomanip>

using namespace std;

#define N 15

#define S 128

int main () {

int mas[S];

for(int n = 0; n < N; n++) {

 mas[0] = 1;

 for(int i = 1; i <= n ; i++)  

  mas[i] = 0;

 for(int i = 1; i <= n; i++)

  for(int j = i; j >= 1; j--)

   mas[j] += mas[j-1];

 cout << setw(2) << n << ":";

 for(int i = 0; i < 35 - 5 * n / 2; i++)

  cout << " ";

 for(int i = 0; i <= n ; i++)

  cout << setw(5) << mas[i];

 cout << endl;

}

   return 0;

}


Напишите программу которая отобразит числа в порядке пирамиды паскаля. программа должна вычислить и
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика