Напишите программу, которая оценит справедливость конспирологического тарифа. Из списка чисел нужно выбрать те, что имеют ту же чётность, что и минимальное.

Формат ввода
Вводится строка целых чисел, записанных через пробел.

Формат вывода
Вывести числа, которые имеют ту же чётность, что и наименьшее, без повторений, порядок вывода неважен.

Пример 1
Ввод
2 5 17 3 18 6 1 9
Вывод
1 3 5 9 17

Olivka09 Olivka09    3   12.12.2020 07:17    16

Ответы
KateHe KateHe  11.01.2021 07:19

a = list(map(int, input().split()))

m = min(a)

res = []

for i in range(len(a)):

   if(a[i]%2==m%2 and a[i] not in res):

       res.append(a[i])

for row in range(len(res)):

   print(res[row], end=' ')

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика