Напишите программу, которая о трех числа решает могут ли они быть сторонами прямоугольного треугольника. напишите программу так чтобы любое число могло быть гипотенузой. паскаль

Yanaaa13 Yanaaa13    3   26.09.2019 18:40    7

Ответы
klochkovanastsy klochkovanastsy  08.10.2020 20:51
PascalABC.NET 3.4.0, сборка 1671 от 31.05.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadSeqInteger('Введите стороны прямоугольника',3).Sorted.ToArray;
  if Sqr(a[2])=Sqr(a[0])+Sqr(a[1]) then Writeln('Могут')
  else Writeln('Не могут')
end.

Напишите программу, которая о трех числа решает могут ли они быть сторонами прямоугольного треугольн
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика