Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число -1, если ни один элемент не повторяется. входные данные первая строка содержит размер массива n . во второй строке через пробел n чисел – элементы массива. гарантируется, что 0 < n ≤ 10000 . выходные данные программа должна вывести максимальный повторяющийся элемент в массиве или число -1, если ни один элемент не повторяется.
a:array [1..10000] of integer;
i,n,a_max,c;
begin
read(n);
a_max:=0;
c:=0;
for i:=1 to n do
begin
a[i] := random(100); // автозаполнение массива
print(a[i]);
if a[i]>a_max then a_max:=a[i]; // поиск максимального элемента
end;
writeln;
for i:=1 to n do
if a[i]=a_max then inc(c); // поиск повторяющихся элементов
if c>=2 then write(a_max)
else write(-1);
end.