Напишите программу, которая находит частное (суммы всех четных чисел) / (Разность всех нечетных чисел), записанных в файле в столбик, и выводит результат в другой файл.

gaviren gaviren    1   16.05.2020 13:19    2

Ответы
brain09 brain09  14.10.2020 20:37

#include <iostream>

using namespace std;

signed main() {

   freopen("input.txt","r",stdin);

   freopen("output.txt","w",stdout);

   int x;

   double sum = 0,dif = 0;

   while(cin >> x){

       if(x % 2 == 0)

           sum += x;

       else

           dif -= x;

   }

   cout << sum/dif;

   fclose (stdout);

}

ПОКАЗАТЬ ОТВЕТЫ
eliseyivanov9 eliseyivanov9  14.10.2020 20:37

// PascalABC.NET

begin

 var (se, so) := (0, 0);

 foreach var s in ReadLines('input.txt') do

 begin

   var t := s.ToInteger;

   if t.IsEven then

     se += t

   else

     so += t

 end;

 WriteAllText('output.txt', (se / so).ToString)

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика