Напишите программу, которая меняет местами первую и последнюю цифру натурального трехзначного числа. (abc pascal)

osumika osumika    1   04.08.2019 20:30    0

Ответы
Алуопо Алуопо  03.10.2020 22:29
Var
a,chislo,t:longint; 
c,nov,posl:integer; 
begin 
readln(a); 
posl:=a mod 10; 
chislo:=a; 
t:=1; 
repeat 
a:=a div 10; 
t:=t*10; 
until a<10; 
chislo:=chislo mod t; 
chislo:=posl*t+chislo-posl+a; 
writeln(chislo); 
readln; 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика