Напишите программу которая меняет местами две соседних элемента списка (а[0] и а[1],а[3]... и т.д.). Если количество элементов нечётное,то последнее число должно оставаться на месте питон ​

danilabarsap02au2 danilabarsap02au2    2   05.03.2021 17:55    4

Ответы
danil820 danil820  05.03.2021 18:00

a = [int(i) for i in input().split()]

for i in range(1, len(a), 2):

   a[i - 1], a[i] = a[i], a[i - 1]

print(' '.join([str(i) for i in a])

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика