Напишите программу, которая для заданной точки с координатами (х,у) определяет, где она расположена: на какой оси или в какой координатной четверти

Виктория58928663 Виктория58928663    3   28.06.2019 18:20    0

Ответы
milana374 milana374  22.07.2020 21:26
Pascal

 var   
x,y : integer;    
begin 
readln (x,y); 
if (x=0) or (y=0)
then   
begin   
if x = 0 then
     writeln ('Точка лежит на оси y');   
if y = 0 then
     writeln ('Точка лежит на оси x')'   
end 
else 
 begin 
   if (x>0) and (y>0) then
     writeln ('Точка находится в первой четверти'); 
   if (x<0) and (y>0) then
     writeln ('Точка находится во второй четверти'); 
   if (x<0) and (y<0) then
     writeln ('Точка находится в третей четверти'); 
   if (x>0) and (y<0) then
     writeln ('Точка находится в четвертой четверти');
  end; 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика