Напишите программу, которая бы определяла среднее арифметическое значение элементов массива (конечно, это будет вещественная величина типа real)

karamanilya karamanilya    3   09.09.2019 01:50    1

Ответы
Виола122006 Виола122006  09.09.2020 22:38
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
  Writeln('Среднее значение равно ',a.Average);
end.

Пример
n= 15
-50 -39 -10 49 35 -11 -34 34 -28 37 45 45 -24 42 2
Среднее значение равно 6.2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика