Напишите программу, которая будет считывать с клавиатуры пароль и проверять соответствует ли
введенный пароль требованиям и возвращает True,
если соответствует и False, если нет. Пароль должен
содержать:

а) буквы (регистр не важен)

б) как минимум одну цифру

А также НЕ должен содержать пробелов.

Glupuj Glupuj    2   31.03.2021 15:25    3

Ответы
paradoksina paradoksina  30.04.2021 15:27

python

password  = input()

have_letter = False

have_diggit = False

have_space = False

for i in password:

 if i.isalpha():

   have_letter = True

 elif i.isdigit():

   have_diggit = True

 elif i == ' ':

   have_space = True

if have_letter and have_diggit and not have_space:

 print(True)

else:

 print(False)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика