Напишите программу для паскаля: 1) разработайте алгоритм для ввода в память эвм линейной таблицы в, состоящей из 8 элементов вещественного типа. ввод организуйе без использования цикла 2) разработайте алгоритм для ввода в память эвм одномерного массива с состоященр из 7 элементов целого тип. ввод организуйе с исползованием цикла "для". 3) разработайте алгоритм для ввода в память эвм одномерного массива д состоящего из 10 элементов целого типа. каждый элемнт вычислите по формуле: значение элемента равно квадрату его индекса

LetovSup LetovSup    2   19.05.2019 00:20    0

Ответы
simakanna simakanna  12.06.2020 05:53

{НАПИШИТЕ ПРОГРАММУ ДЛЯ ПАСКАЛЯ:
1) Разработайте алгоритм для ввода в память ЭВМ линейной таблицы В,
 состоящей из 8 элементов вещественного типа. Ввод организуйе без использования цикла
2) разработайте алгоритм для ввода в память ЭВМ одномерного массива С
 состоященр из 7 элементов целого тип. Ввод организуйе с исползованием цикла "ДЛЯ".
3) разработайте алгоритм для ввода в память ЭВМ одномерного массива Д
 состоящего из 10 элементов целого типа.
 Каждый элемнт вычислите по формуле: значение элемента равно квадрату его индекса}

var
    B: array [1..10] of real;
    C: array [1..10] of integer;
    D: array [1..10] of integer;
    i:integer;

begin
    writeln('Введите 8 элементов В');
    read(b[1], b[2], b[3], b[4], b[5], b[6], b[7], b[8]);
    
    writeln('Введите 7 элементов C');
    for i := 1 to 7 do read(C[i]);
    
    for i := 1 to 10 do D[i] := i * i;
    
    writeln();
    for i := 1 to 8 do write(B[i], ' ');
    writeln();
    for i := 1 to 7 do write(C[i], ' ');
    writeln();
    for i := 1 to 10 do write(D[i], ' ');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы