Напишите программу для нахождения минимальной и максимальной цифры в числе.язык c++

karalina200215 karalina200215    1   09.12.2019 22:26    0

Ответы
198219821982 198219821982  10.10.2020 19:39

#include <iostream>

#define max 100

using namespace std;

int index;

char input = 0;

int ln;

char min = '9' + 1;

char max = '0';

int nul;

int main()

{

   cin >> input;

   

   for(int j = 0; input[j] != '\0'; j++){

       ln = j + 1;

   }

   

   for(int j = 0; j < ln ; j++){

       if( input[j] < min){

           min = input[j];

       }

   }

   

   for(int j = 0; j < ln ; j++){

       if (input[j] > max){

           max = input[j];

       }

   }

   cout << "max:" <<  max;

   cout << "min:" << min;

   cin >> nul;

   

   return 0;

}

P.S.я не уверен, если у тебя не запуститься пиши

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика