Напишите программу. Числа Фибоначчи (fn) определяются формулами f0=f1=1; fn=fn-1+fn-2 при n=1,2..., тоесть это бесконечная последовательность чисел вида: 1,1,2,3,5,8,13,21,34,55,89,...Определите номер последнего числа Фибаначчи , который входит в диапазон от 1 до 2^16

tynvik tynvik    3   15.03.2021 20:16    0

Ответы
Dumbass1007 Dumbass1007  14.04.2021 20:17

var

 v, c, a, b, n,count: integer;

begin

 write('Введите максимальное число N = '); readln(n);  

 a := 0; b := 1;

 count:=1;

 repeat

   c := b;

   b := a + b;

   a := c;

   v := a + v;

   inc(count);

 until v-a>n;

 writeln(count,': ',a);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика