Напишите на паскале. : написать программу, определяющую, можно ли треугольник со сторонами a, b, c поместить внутри круга радиусом r

ivankal ivankal    2   18.08.2019 17:40    1

Ответы
hopelless2124 hopelless2124  05.10.2020 03:13
Var a,b,c,r,s,p: real;
begin
  write('длины сторон треугольника a,b,c через пробел: ');
  readln(a,b,c);
  write('радиус круга r: ');  readln(r);
  p:=(a+b+c)/2;
  s:=sqrt(p*(p-a)*(p-b)*(p-c));
  if r>=(a*b*c)/(4*s) then writeln('можно поместить')
  else writeln('нельзя поместить');
end.

длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.49
нельзя поместить

длины сторон треугольника a,b,c через пробел: 3 4 5
радиус круга r: 2.5
можно поместить
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика