Напишите алгоритм в виде программы на паскале напишите ая алгоритм вычисления у по формуле у=(1-х²+5х^4)², где х- заданное число. учтите следующие ограничения: 1) в арифмитических выражения можно использовать только операции сложения, вычитания и умножения. 2) каждое выражение может содержать только одну арифметическую операцию. выполните трассировку алгоритма при х= 2. добавлю за ответ без

pirozhkovanastya pirozhkovanastya    1   23.07.2019 12:20    9

Ответы
xuimorjovi xuimorjovi  03.10.2020 11:34
Var x,x2,x4,y:real;
begin
write('x = '); readln(x);
x2:=x*x;
x4:=x2*x2;
x4:=5*x4;
y:=1-x2;
y:=y+x4;
y:=y*y;
writeln('y = ',y);
end.

Пример:
x = 2
y = 5929

Трассировка:
x=2
x2=2*2=4
x4=4*4=16
x4=5*16=80
y=1-4=-3
y=-3+80=77
y=77*77=5929
ПОКАЗАТЬ ОТВЕТЫ
kekkekkeksos kekkekkeksos  03.10.2020 11:34
Var x,y:real;
begin
write('Введи x = ');readln(x);
y:=(1-x*x+5*x*x*x*x)*(1-x*x+5*x*x*x*x);
writeln('y = ',y);
end. 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика