Написать программу замены положительных элементов вещественного массива y[1..n] на 0. (паскаль-массивы)

дарууунчик дарууунчик    3   08.06.2019 16:10    0

Ответы
30Космос03 30Космос03  07.07.2020 19:05
Решение в файле

uses crt;
var a: array of integer;    n, i: integer;    begin
WriteLn('Введите N');ReadLn(n);
a := new integer[n];
randomize; //заполняем массив случайными значениямиfor i:=0 to n-1 dobegina[i]:=random(100)-50;Write(a[i]:5);end;Writeln;
for i:=0 to n-1 do //заменяем положительные элементы нулемbeginif a[i]>0 then a[i]:=0;Write (a[i]:5);end;writeln;readln;end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика