:написать программу, вычисляющую произведение элементов одномерного массива z(n). рекомендация: посмотрите алгоритм нахождения суммы и обратите внимание на то, что произведение p: =p*z[k] перед циклическим процессом нужно задать как 1, т.е. p: =1; ввод и вывод массива выполните через текстовый файл.

ksuynya2007 ksuynya2007    1   16.07.2019 10:50    0

Ответы
Katerinka890 Katerinka890  21.09.2020 09:58
Class ArrayMultiplication{
 public static void main(String args[]){
  String fileName = "Array.txt", aNum = ""; int nArray[] = new int[201], iChar; nArray[0] = 0; long rMulti;
  java.io.FileReader iFile = null; java.io.FileWriter oFile = null;
  try{
   iFile = new java.io.FileReader(fileName);
   while((iChar = iFile.read())!=-1)
    if(iChar!=' ')aNum+=(char)iChar;
    else {nArray[++nArray[0]] = new Integer(aNum);aNum="";}
   if(!aNum.equals(""))nArray[++nArray[0]] = new Integer(aNum);
   oFile = new java.io.FileWriter(fileName);
   for(rMulti = 1; nArray[0]>0; nArray[0]--)rMulti*=nArray[nArray[0]];
   oFile.write(rMulti+"");
  }catch(java.io.FileNotFoundException fnfe){
   System.out.println("Файл не был найден!");
  }catch(java.io.IOException ioe){
   System.out.println("Ошибка ввода/вывода в файл!");
  }finally{
   try{
 iFile.close(); oFile.close();
   }catch(java.io.IOException ioe){
 System.out.println("Ошибка закрытия файла ввода/вывода!");
   }
  }
 }
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика