Написать программу вводя числа с клавиатуры без ограничения их количества (конец ввода - число 0), найти сумму положительных и произведение отрицательных чисел ..

osmyhinaozd6ev osmyhinaozd6ev    3   02.04.2019 06:30    0

Ответы
Лина1990 Лина1990  28.05.2020 10:18

program c1;
var
a,b,n:longint;
Begin
a:=0;
writeln('Вводи числа sergei1906');

repeat
read(n);
if n>0 then b:=b+n;
if n<0 then a:=a*n;
until n=0;
Writeln('Сумма положительных чисел: ',b);
Writeln('Произведение отрицательных чисел: ',a);
End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика