Написать программу вхождения каждого символа в текст, содержащийся в файле в формате txt, на языке программирования высокого уровня basic (можно либо на qbasic или на visual basic)?

katyat1510 katyat1510    3   08.06.2019 23:50    2

Ответы
vika2499 vika2499  07.07.2020 22:50
Const
  T = '';
  n = 66;//  Количество символов в Т

var
  s,buf: string;
  P: array[1..n] of integer;
  i, k: integer;
  F: Text;

begin
  Assign(F, 'CharCount.txt');
  Reset(F);
  s:='';
  while not SeekEof(F) do begin
    Read(F,buf);
    s:=s+buf
  end;
  Writeln(s);
  for i := 1 to n do P[i] := 0;
  for i := 1 to length(s) do
  begin
    k := Pos(s[i], T);
    if k > 0 then P[k] := P[k] + 1
  end;
  for i := 1 to n do
    if P[i] > 0 then writeln(T[i], ' - ', P[i]:3)
end.

Тестовый пример:
Ксаверий Феофалактович Грушин, следственный пристав Сыскного управления при московском обер-полицмейстере,облегченно вздохнул и отложил влево, в стопку "просмотрено", сводку важных преступлений за вчерашний день
Г -   1
К -   1
С -   1
Ф -   1
а -   8
б -   2
в -  13
г -   2
д -   4
е -  17
ж -   2
х -   2
и -  11
й -   5
к -   6
л -  10
м -   4
н -  13
о -  20
п -   8
р -  11
с -  12
т -   8
у -   6
ф -   1
ц -   1
ч -   3
ш -   2
ы -   3
ь -   1
я -   1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика