Написать программу в турбо паскале. : дан текстовый файл f. исключить гласные буквы из строк и поместить результат в файл q.

denislabynsky denislabynsky    2   09.06.2019 06:40    0

Ответы
Виктория2478 Виктория2478  01.10.2020 22:53
var
  f, q: Text;
  i: integer;
  s: string;

begin
  Assign(f, 'in.txt');
  Reset(f);
  Assign(q, 'out.txt');
  rewrite(q);
  while not EOF(f) do
  begin
    readln(f, s);
    i := 1;
    while (i <= length(s)) do
    begin
      if (upcase(s[i]) in ['А', 'Е', 'Ё', 'И', 'О', 'У', 'Ы', 'Ю', 'Я']) then
        delete(s, i, 1);
      inc(i);
    end;
    writeln(q, s);
  end;
  close(f); close(q);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика