Написать программу в с++, которая проверяла бы: "число армстронга или нет". если что, число армстронга-это число в котором сумма цифр=самому числу. причем каждая цифра в таком степени, сколько цифр в самом числе, например число 153-армстронга, потому что 153=1³+5³+3³. если можно,напишите программу так, чтоб я, как новичок понял, решить через функции.

alexandrapavlov1 alexandrapavlov1    1   07.09.2019 06:50    1

Ответы
Васелёк05 Васелёк05  06.10.2020 22:36
#include <iostream>
#include <cmath>
using namespace std;

void isArmstrong(const int number)
{
int origNum, num, rem, sum = 0;
origNum = number;
num = origNum;
while(num != 0) {
rem = num % 10;
sum += pow(rem, 3);
num /= 10;
}

if(sum == origNum)
cout << origNum << " is an Armstrong number.";
else
cout << origNum << " is not an Armstrong number.";
}

int main()
{
isArmstrong(153);
return 0;
}

С проверкой https://ideone.com/keY6PS
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика