Написать программу в python программа просит ввести основание и прилегающую высоту треугольника, присваивает введённые значения переменным a и h, вычисляет площадь треугольника и печатает значения a, h и площади треугольника. вычисление площади треугольника оформлено в виде функции.

ilinet ilinet    3   23.08.2019 09:40    5

Ответы
ilchumakovsky1 ilchumakovsky1  02.08.2020 21:22
# coding: utf-8
# Python 3.X

'''
Программа просит ввести основание
и прилегающую высоту треугольника,
присваивает введённые значения
переменным a и h, вычисляет площадь
треугольника и печатает значения
a, h и площади треугольника.
Вычисление площади треугольника
оформлено в виде вс
функции.
'''

def trig_area(a, h):
    a = 0.5 * a * h
    if a.is_integer():
        return int(a)
    else:
        return a

a = int(input('Введите основание: '))
h = int(input('Введите прилегающую высоту: '))
print('\nОснование: {}\nВысота: {}\nПлощадь: {}'.format(a, h, trig_area(a, h)))
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика