Написать программу в python 3.0 суточный рацион коровы составляет a кг сена, b кг силоса и c кг комбикорма. в хозяйстве, содержащем стадо из k голов, осталось x центнеров сена, y тонн силоса и z мешков комбикорма по 50 кг. сколько еще дней хозяйство сможет кормить коров по полному рациону?

luizazamanov luizazamanov    3   26.09.2019 14:20    5

Ответы
Mandarinka0001 Mandarinka0001  08.10.2020 20:21
Запас сена составляет sx=50x кг, запас силоса sy=50y кг, запас комбикорма sz=50z кг.
За сутки k коров съедят dx=ka кг сена, dy=kb кг силоса и dz=kc кг комбикорма, после чего запасы уменьшаются:
sx=sx-dx, sy=sy-dy, sz=sz-dz. Этот процесс повторяется и прекращается, если выполняется хотя бы одно из условий:
sx<dx, sy<dy, sz<dz. Количество таких повторений будет ответом на задачу.

sx = 50*int(input("Мешков сена: "))
sy = 50*int(input("Мешков силоса: "))
sz = 50*int(input("Мешков комбикорма: "))
k = int(input("Количество голов в хозяйстве: "))
dx = k*int(input("Дневной рацион коровы (сено), кг: "))
dy = k*int(input("Дневной рацион коровы (силос), кг: "))
dz = k*int(input("Дневной рацион коровы (комбикорм), кг: "))
d=0
while sx>=dx and sy>=dy and sz>=dz:
    d+=1
    sx-=dx
    sy-=dy
    sz-=dz
print("Коров можно кормить еще "+str(d)+" дней (дня)")

Написать программу в python 3.0 суточный рацион коровы составляет a кг сена, b кг силоса и c кг комб
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика