tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу в паскали.дан
Написать программу в паскали.дан одномерный массив a[n]. найти произведение четных чисел и сумму нечетных.
LadybugfromParis
2 08.06.2019 23:00
0
Ответы
violettakot01
07.07.2020 22:29
Const
n = 5;
var
a: array [1..n] of byte;
s, k: longint;
b: byte;
begin
k := 1;
for b := 1 to n do
begin
a[b] := random(1, 11);
write(a[b]:3);
end;
writeln();
for b := 1 to n do
if (a[b] mod 2 = 1) then
s := s + a[b]
else
k := k * a[b];
for b := 1 to n do
writeln(s, ' ', k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
zaika25901
11.08.2020 09:15
Написать программу на языке Паскаль....
Katya111zz3
12.08.2020 11:00
Число десятков Дано целое неотрицательное число N, определите число десятков в нем (предпоследнюю цифру числа). Если предпоследней цифры нет, то можно считать, что число десятков...
araratpashayan5
11.08.2020 10:29
Aduino как исправить #include #include #include #include #include #define ledPin 8 #define btnPin 4 double number; long sTime; LiquidCrystal_I2C lcd(0x3F, 2, 1, 0, 4, 5, 6, 7, 3,...
СофияСтепанова
23.12.2020 16:46
Оқушыларға қолайлы файл форматтарын таңдауға көмектес: Маратка интернетке бірнеше суретт жүктеу қажет, ал Айнұр презентация жасап, мөлдір фоны бар суреттерді пайдаланғысы келеді.Дұрыс...
DetaRUSION
23.12.2020 16:46
Запишите величины и их значения, определяющие следу- ющие свойстваобъектов:Графический файл - Величина:Значение:Большой файл-Величина:Файл:чень надо...
Марат991
23.12.2020 16:45
для того чтобы распечатать изображение на бумаге какие действия нужно выполнить...
dashalev2510
10.11.2020 11:52
Сообщение о том, что на пешеходном переходе стёрлась четвертая по счёту полоска разметки, несёт 4 бита информации. Какое минимальное количество полос может быть в разметки пешеходного...
denus16
10.11.2020 11:52
Вывести последовательность в пайтон 1 2 4 8 16 32 64 128 256 512...
g2004
10.11.2020 11:53
Условие Дано слово, оканчивающееся символом «!». Вставьте букву m на место k-й буквы. Формат входных данных В трех строках входных данных вводится строчная латинская буква m, натуральное...
GoodT3am
01.06.2019 20:20
Обчисліть скільки часу потрібно для передавання відеокліпу об ємом 160 мб за модему зі швидкістю 800 кбіт/с....
Популярные вопросы
Установіть відповідність між реченнями і їх типами...
1
Розв яжіть рівняння x²-4x-5=0...
1
Прийменник є в кожному реченні, ОКРІМ Не пускайся без весла вморе. .За годину моря...
1
1.Сүйлөмдүн баш мүчөлөрү деген эмне? 2.Ээ баяндооч кандай суроолорго жооп берет...
1
Миром, ТІ даПод лингвистическим микроскопомпсM1. С каких изобразительных средств...
2
Відносна вологість повітря 90%. Яку температуру показує вологий термометр психрометра,...
3
572. Перемалюйте в зошит таблицю. Укажіть кількість граней, ребер і вер- i шин...
2
Постройте график функции у= -1/6х НАДО!...
2
Знайди правильну характеристику числівників із тексту: В Україні перший пам ятник...
2
Придумайте вопросы к предложению:Computers and information systems assist organization....
2
n = 5;
var
a: array [1..n] of byte;
s, k: longint;
b: byte;
begin
k := 1;
for b := 1 to n do
begin
a[b] := random(1, 11);
write(a[b]:3);
end;
writeln();
for b := 1 to n do
if (a[b] mod 2 = 1) then
s := s + a[b]
else
k := k * a[b];
for b := 1 to n do
writeln(s, ' ', k);
end.