Написать программу в паскале! надо! задана последовательность целых чисел,количество которых не превосходит 100.требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.

qwidonsky qwidonsky    1   11.06.2019 16:50    0

Ответы
elshad2003 elshad2003  09.07.2020 15:20
Var
  i,k,max:integer;
  a:array[1..100]of integer;
begin
writeln('Исходная последовательность: ');
for i:=1 to 100 do
  begin
  a[i]:=random(200);
  write(a[i],' ');
  if a[i]>max then
    begin
    max:=a[i];
    k:=1;
    end;
  if a[i]=max then
    k:=k+1;
  end;
writeln;
writeln('Максимальное значение: ',max);
writeln('Число повторений: ',k)
end.
ПОКАЗАТЬ ОТВЕТЫ
ersultanplay ersultanplay  09.07.2020 15:20
Program maxof;
var ar: array [1..100] of integer;
i, j, posl: shortint;
max: integer;
begin
readln(i);
for j:=1 to i do begin
readln(ar[j]);
end;
max:=ar[1];
posl:=1;
for j:=2 to i do begin
if max = ar[j] then inc(posl);
if max < ar[j] then begin posl:=1; max:=ar[j] end; 
end; writeln(max, ' x', posl);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика