Написать программу в паскале дан двумерный массив размером 4*6,заполненный целыми числами с клавиатуры.сформировать одномерный массив,каждый элемент которого равен кол-ву элементов соответствующей строки,больших данного числа.

maksilyutich maksilyutich    3   16.07.2019 11:20    2

Ответы
maxtihvin maxtihvin  03.10.2020 05:37
Var
   x:real;
   arr2: array [1..4,1..6] of integer;
   arr1: array [1..4] of integer;
begin
      writeln('Введи число для сравнения');
      readln(x);
      for var i:=1 to 4 do 
      begin
            writeln('Вводим строку ',i);
            for var j:=1 to 6 do
            begin
                  writeln('Введи число ', j);
                  readln(arr2[i,j]);
                  if arr2[i,j]>x then arr1[i]:=arr1[i]+1;
            end;
    end;
    writeln('Двумерный массив: ', arr2, ' Количество чисел больше заданного: ', arr1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика