Написать программу в паскале автобус провозит 50 пассажиров. из них 10 едут до первой станции, 20 - до второй, а остальные до конечной. стоимость билетов до каждой станции соответственно равна a,b,c. определите сколько рейсов должен делать автобус. чтобы выручка составила к руб?

ЗАЙКА200515 ЗАЙКА200515    2   27.09.2019 15:30    3

Ответы
Алёна280104 Алёна280104  08.10.2020 22:55

var a, b,c,k,d,e,g,h : integer;

var f : integer;

begin

writeln('Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел :');

readln(a,b,c);

writeln('Введите сколько рублей должна быть конечная выручка : ');

readln(k);

d := 10*a;

e := 20*b;

g := 20*c;

h := d+e+g;

f := h div k;

writeln(f, ' Рейсов нужно совершить нужно совершить.');

end.

Лог :

Введите стоимости билета за проезд до первой, до второй и до конечной станции через пробел :

1

1

1

Введите сколько рублей должна быть конечная выручка :  

50

1 Рейсов нужно совершить нужно совершить.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика