Написать программу в паскале. 3. нужно написать обязательно через циклы, без использования процедур и функций, только циклы.​

DmitriiSh197 DmitriiSh197    1   31.03.2019 13:08    2

Ответы
muratovsergej muratovsergej  27.05.2020 22:54

var x,s,p,p1: real;i,n:integer;

begin

readln (x,n);

s:=1;

p:=1;

p1:=1;

i:=2;

while i<=n do

begin

  p:=(-1)*p*x*x;write('p=',p);

  p1:=p1*i*(i-1);write('  p1=',p1);

  s:=s+p/p1; writeln('   i=',i,'  s=',s);

  i:=i+2;

  writeln;

end;

if n=1 then write(1) else writeln( 's= ', s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика