Написать программу в pascalabc.net задано натуральное число .напишите программу ,которая для число с нечётным количеством цифр выведет на экран цифру , стоящую на средней позиции числа .

РаскольниковРодион РаскольниковРодион    1   08.03.2019 16:57    110

Ответы
Мария3467 Мария3467  07.06.2020 00:05

var

 x, a, k, t, i, d: integer;

begin

 readln(x);

 a := x; k := 0;

 while a > 0 do

 begin

   k += 1;

   a := a div 10;

 end;

 if k mod 2 = 0 then

   write('В числе четное количество цифр')

 else

 begin

   t := 1;

   for i:=1 to k div 2 do

     t *= 10;

   d := x div t mod 10;

   write(d);

 end

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика