Написать программу в pascal. найдите сумму всех целых чисел [a; b]заранее .

olyamin0 olyamin0    2   31.08.2019 06:00    0

Ответы
nazira15 nazira15  26.08.2020 12:43
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a,b:integer; Read(a,b);
  Writeln('S=',Range(a,b).Sum)
end.

Пример
8 42
S=875
ПОКАЗАТЬ ОТВЕТЫ
милана695 милана695  26.08.2020 12:43
Var
   a,b:integer;
   S:real;
Begin
S:=0;
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
For b:= a to b do
    S:=S+b;
WriteLn('S = ',S);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика