Написать программу: в массиве из 10 вводимых с клавиатуры чисел подсчитать количество чисел кратных первому элементу, но не кратных последнему элементу.  ​

balasanyansilva balasanyansilva    1   18.03.2019 12:22    1

Ответы
Artemka1337w Artemka1337w  26.05.2020 00:01

var

   numbers: Array[1..10] of Integer;

   i, first, last, count, num: Integer;

begin

   writeln('Введите 10 чисел');

   

   for i := 1 to 10 do

       readln(numbers[i]);

   first := numbers[1];

   last := numbers[10];

   

   for i := 1 to 10 do begin

       num := numbers[i];

       

       if (num >= first) and (num mod first = 0) then

           if (num < last) or (num mod last <> 0) then

               count := count + 1;

   end;

   

   writeln(count);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика